Quick Newsletter をPHP7に対応させる

必ずご確認ください :  2017年9月1日現在、Quick Newsletter は、PHP7.1 では動作しません(状況によっては、PHP7.0.x でも動作しません)。アップデートを待つか(toiee Labのソフトではありませんので、HAIK Teamに尋ねてください)、Webサービスに移行を考えてください。なお、toiee Lab では、 Mailerlite  をお勧めしています。

ここでは、QNewsletter を PHP7に対応させる方法を説明します。

注意、重要: QNewsletterは、 HAIK Team(他社) の製品です。オープンソース部分を変更したものを独自に配布しています。最終的には、HAIK Team にお問い合わせください。

原因

QNewsletterの中で、PHP7に対応していないソースコードがあります。具体的には、オブジェクト生成時に、参照渡しを行なっている部分です。これは、QHMのおまじないをHTMLコードに変更する部分でもあります。


解決方法

QNewsletterのシステムを設置している場所に、以下のファイルを解凍し上書きしてください(FTPソフトなどを使う)

あるいは、QNewsletter をアップデート(修復)を実行してください。HAIK Team に働きかけて、PHP7に対応するバージョンを渡しておきました。

https://ensmall.net/p/qnews/

ヒント:  QNewsletter もいいですが、Mailerlite がとても便利です。計測や多くのメールソフトに対応したHTMLメールが送れます。しかも、無料スタート(2000人まで)。 詳しくは、こちら

関連する耳デミー

関連するポケてら